Logo       PBase-Foundation

Java

Java JRE and Development Tools Check for existing Java version if needed. One an existing system you may need to remove an existing version of Java. Here's an example of removing Java 1.7.

yum remove java*
yum remove java-1.7.0-openjdk*

Only if needed, choose your version of Java. Here's commands to install either version 1.8 or 11.

yum -y install java-1.8.0-openjdk-devel
##OR
yum -y install java-11-openjdk-devel

to get Java along with Maven and other developer command line tools

yum -y install pbase-java8-dev-tools
##OR
yum -y install pbase-java11-dev-tools

Tomcat 8 Install and start service

yum -y install pbase-tomcat8