Logo       PBase-Foundation

Elasticsearch

Here is how to install and start the elasticsearch service. Requires the Java 1.8 JRE to be already installed before installing the elasticsearch package. This module is specifically for Elasticsearch version 6.4.2 which is compatible with Spring Boot.

yum -y install http://pbase-foundation.com/pbase-repo.rpm
yum -y install java-1.8.0-openjdk
yum -y install pbase-preconfig-elasticsearch
yum -y install pbase-elasticsearch

(You may need to reboot to let the elasticsearch service start correctly.) When install is done, you may load the shell-aliases from .bashrc and run the "tailelastic" alias.

source ~/.bashrc
tailelastic

Configuration Options

The pbase-preconfig-elasticsearch rpm creates a sample configuration file that can be customized:

{
"pbase_elasticsearch" : {
"startservice": true,
"firewalladdport": true,
"port": 9200,
"node_master": false,
"node_name": "node-1",
"cluster_name" : "my-application"
}
}